NumberTriangles triangles

Description

Consider the number triangle shown below. Write a program thatcalculates the highest sum of numbers that can be passed on a routethat starts at the top and ends somewhere on the base. Each stepcan go either diagonally down to the left or diagonally down to theright.

          7        3   8      8   1   0    2   7   4   4  4   5   2   6   5

In the sample above, the route from 7 to 3 to 8 to 7 to 5produces the highest sum: 30.

Input

The first line contains R (1 <= R<= 1000), the number of rows. Each subsequent linecontains the integers for that particular row of the triangle. Allthe supplied integers are non-negative and no larger than 100.

Output

A single line containing the largest sum using the traversalspecified.

Sample Input

573 88 1 02 7 4 44 5 2 6 5

Sample Output

30

#include<iostream>
NumberTriangles triangles
using namespace std;
int main()
{
intn,i,j;
cin>>n;
int **a=newint *[n];
for(i=0;i<n;i++)
a[i]=new int[i+1];
for(i=0;i<n;i++)
for(j=0;j<=i;j++)
cin>>a[i][j];
for(i=n-2;i>=0;i--)
for(j=0;j<=i;j++)//从下往上依次遍历!
a[i][j]+=(a[i+1][j]>a[i+1][j+1])?a[i+1][j]:a[i+1][j+1];
cout<<a[0][0]<<endl;
}

  

爱华网本文地址 » http://www.aihuau.com/a/25101016/288628.html

更多阅读

苹果创新细节 李彦宏 公司创新细节为王(2)

 在李彦宏看来,2005年6月推出的“知道”是百度另一个比较成功的产品,通过群众聪明使得搜索引擎解决了自然语言识别问题,使用户查找搜索结果更加便利。现在,“知道”问答论坛已经回答了近2000万个问题,已经成了对网民最有吸引力的产品之

初中地理教学反思 初中地理教学反思(4篇)

初中地理教学反思(篇1)在现代的教学中,我觉得现在我体验最深的一条是改变满堂灌的教学模式,尝试创新的教育理论,做到教、 学、 做合一的教学,重视对学生知识的传授,更要重视对学生能力的培养。教师教育观念的更新、学生学习方式的转变是

雷锋的故事读后感格式 《雷锋的故事》读后感300字

《雷锋的故事》读后感300字雷锋自幼就丧了父母、爷爷、哥哥与弟弟,共产党收留了他,从此他开始了帮助别人的生活。这本书让我感悟很大,更觉得雷锋是一名英雄,在他入伍之后写了一句话,特别令我受益,那就是“革命需要我烧木炭,我就去做张思

关于热爱读书的名言 关于热爱读书名言

  关于热爱读书的名言  1、读书如饭,善吃饭者长精神,不善吃者生疾病。  2、重要的不是知识的数量,而是知识的质量,有些人知道很多很多,但却不知道最有用的东西。  3、书就是社会,一本好书就是一个好的世界,好的社会。它能陶冶人

声明:《NumberTriangles triangles》为网友夏日的綠色分享!如侵犯到您的合法权益请联系我们删除